Как сделать подсчет слов в TextEdit на Mac

Как сделать подсчет слов в TextEdit на Mac
TextEdit, простая программа текстового редактора, встроенная в macOS (и Mac OS X до нее), обладает многими привлекательными качествами — настолько, что эта статья в настоящее время набирается в нее, несмотря на присутствие гораздо более полнофункциональных Word и Pages на тот же Mac. Но у этого есть одно явное ограничение: нет никакого количества слов.

В этом уроке мы познакомим вас с довольно простым методом добавления функции подсчета слов в TextEdit на Mac. Затем мы обсудим некоторые более простые (если менее удовлетворительные) обходные пути, которые вы можете попробовать, если первый выглядит пугающим.

Создать точное количество слов в TextEdit

Откройте Automator. (Он свободно работает в приложениях, или вы можете найти его с помощью Spotlight.) Он попросит вас выбрать тип для вашего документа; нажмите Сервис, затем выберите. (Если он не спрашивает об этом, вам, возможно, придется нажать «Новый документ», чтобы перейти к нужному экрану.)

Вверху оставьте первый бит («Выбран сервис получен») как «текст». Щелкните по второму (по умолчанию «любое приложение»), чтобы открыть выпадающее меню, выберите «Другое», затем найдите и выберите «TextEdit».

Как сделать подсчет слов в TextEdit на Mac: Automator

Убедитесь, что библиотека выбрана в левой панели (нажмите «Библиотека» в верхней панели, если эта панель не отображается) и прокрутите вниз, пока не найдете действие «Выполнить сценарий оболочки» (в алфавитном порядке). Перетащите это на правую панель.

Как сделать подсчет слов в TextEdit на Mac: Automator

Не меняйте другие параметры. Просто вставьте следующий текст (созданный Tony T1 в этой ветке обсуждения Apple), в точности так, как он есть, кавычки, странные имена файлов и все, в текстовое поле поверх надписи «cat»:

Читайте также:  Как просматривать клипы, трейлеры и фильмы iMovie Theatre на любом устройстве с помощью iCloud

osascript <<-AppleScriptHereDoc
расскажите приложение «TextEdit»
установить word_count для подсчета слов документа 1
установите char_count для подсчета символов документа 1
установите show_words в (word_count как строка) «слова. (» (char_count как строка) » персонажи.)»
установите dialog_title в «TextEdit Word Count»
отображать диалог show_words со значком 1 с заголовком dialog_title button {«Ok»} кнопка по умолчанию «Ok»
конец сказать
AppleScriptHereDoc

Теперь нажмите «Файл»> «Сохранить» и сохраните сервис как Word Count или аналогичный. Выйти из Автоматора.

Как сделать подсчет слов в TextEdit на Mac: Automator

И это все! В документе TextEdit выберите любой бит текста (он не работает без выделенного текста) и щелкните правой кнопкой мыши. Новая команда Word Count должна была появиться внизу. (В High Sierra вам придется выбрать Сервисы> Количество слов.)

Как сделать подсчет слов в меню TextEdit: High Sierra

Нажмите на это, и вы получите количество слов для всего документа (а не для выделенного текста, так что нет, это все еще не идеальное решение).

Как сделать подсчет слов в TextEdit на Mac: Automator

Более простые обходные пути

Если вы не заинтересованы в Automator, есть несколько более простых решений, которые вы можете использовать вместо этого.

Используйте функцию поиска TextEdit

Этот обходной путь не является точным, и опять же вы можете использовать его только для подсчета слов всего документа, но, по крайней мере, это то, что вы делаете в самом TextEdit.

В документе TextEdit нажмите «Правка»> «Найти»> «Найти» (или, проще, Cmd + F), чтобы открыть поле «Найти». Щелкните значок поиска (увеличительное стекло) в левом конце поля и выберите «Вставить шаблон» в раскрывающемся меню. Во второй группе параметров вы увидите «Любые символы слова». Нажмите это.

Как сделать подсчет слов в TextEdit на Mac: Найти

Функция Find теперь будет запускать поиск любых слов. Вы увидите все эти слова выделенными, а число — количество слов — в правом конце поля «Найти». Шаблон Word остается в поле Find, поэтому в любое время вам просто нужно нажать Cmd + F, чтобы получить еще один счет. Однако это становится неловким, если вам нужно что-то найти и заменить.

Читайте также:  Мастер-класс Macworld: анимация масок во Flash

Как сделать подсчет слов в TextEdit на Mac: Найти

И быстрый взгляд на выделенные слова покажет, что они не совсем точны, особенно в отношении слов с апострофами. (Например, в разных случаях, в зависимости от форматирования, мы думаем, что «вы «- это два слова, или вообще нет слов.) Так что это хорошо для того, чтобы дать грубую идею, но она будет постоянно занижаться или переоцениваться на несколько процентов, в зависимости от случайности вашего стиля письма.

Обмануть! Вставить в другую программу

Наконец, и на тот случай, если вам это еще не пришло в голову, давайте очень быстро упомянем чит-метод, на который опиралось большинство из нас, прежде чем решить эту проблему.

В документе TextEdit выберите все (Cmd + A) или выделите текст, который вы хотите использовать для подсчета слов, затем перейдите к документу в программе, в которой есть счетчик слов — мы чаще всего используем Google Docs, но Microsoft Word и Apple Pages — другие варианты — вставьте их с помощью Cmd + V, а затем выполните подсчет слов. (В Документах Google используйте Инструменты> Количество слов или Cmd + Shift + C.)

Это неудовлетворительно с точки зрения решений, но, по крайней мере, позволяет получить количество слов для выбранного текста, а не для всего документа.

Ссылка на основную публикацию
Adblock
detector